RFC: JDWP ExceptionEvent Notification
Tom Tromey
tromey@redhat.com
Thu Aug 31 19:52:00 GMT 2006
>>>>> "Kyle" == Kyle Galloway <kgallowa@redhat.com> writes:
Kyle> Comments, or can I commit this?
A few comments, some stylistic, some pedantic.
Kyle> 2006-08-30 Kyle Galloway <kgallowa@redhat.com>
Kyle> * interpret.cc: Added #includes for JDWP.
Before the "*" should be a single tab character.
Kyle> +/* ExceptiontManager.java -
Typo.
Kyle> + private ExceptionManager()
Kyle> + {
Kyle> + //this holds the references to the throwables
Indentation looks off here.
There's a tab in there but it should be 4 spaces.
Basically all the indentation in the patch is wrong...
Kyle> + System.out.println("EventManager Add: " + t);
Did you want these in there?
Kyle> + util::Location* loc
Kyle> + = new util::Location (method, meth->insn_index ((insn_slot*)logical_pc));
I think you can only use insn_index if DIRECT_THREADED.
Perhaps you could define insn_index as the identity function in the
non-DIRECT_THREADED case though...
Kyle> +#ifdef DEBUG
Kyle> + //report the uncaught exception
Kyle> + if (::gnu::classpath::jdwp::Jdwp::isDebugging)
Kyle> + {
Kyle> + using namespace ::gnu::classpath::jdwp;
Kyle> + jlong methodId = reinterpret_cast<jlong> (meth->self);
Kyle> + VMMethod* method
Kyle> + = VMVirtualMachine::getClassMethod (meth->defining_class, methodId);
A lot of this looks like duplicated code... would a helper function be
appropriate?
Tom
More information about the Java-patches
mailing list