[committed] Fix problem with the rename of pp_format_text to pp_format in the java front-end

Gabriel Dos Reis gdr@integrable-solutions.net
Fri Jul 1 15:15:00 GMT 2005


Zack Weinberg <zack@codesourcery.com> writes:

| Andrew Pinski <pinskia@physics.uc.edu> writes:
| 
| > This fixes the problem with compiling the java front-end.
| 
| This is, sadly, not a complete fix.  pp_format() does not produce

agreed.

| output; you need to call pp_output_formatted_text() too.  (The name is
| confusing, yes; feel free to rename it to something more sensible, if
| you can think of one.)  See pretty_print.c:pp_printf() for the proper
| way to do it.

Part of what made reviewing your change difficult was the
implementation of intended semantics combined with renaming.  In
retrospect, those renamings should have been kept to the minimum, not
just you did not like them.

-- Gaby



More information about the Java-patches mailing list