[patch] add --with-java-home configure option
Thomas Fitzsimmons
fitzsim@redhat.com
Wed Apr 6 03:55:00 GMT 2005
Hi,
On Tue, 2005-04-05 at 14:31 -0400, Bryce McKinlay wrote:
>
> How about "overrides the default value of ..." - sounds a bit more clear?
>
OK.
>
> Likewise, shouldn't need JAVA_HOME_SET if you just "AC_DEFINE
> (JAVA_HOME, ...)" and leave it undefined in the other case.
>
AC_DEFINE/AC_DEFINE_UNQUOTED doesn't work for defining configure
directory values. ${prefix} can have a value of "NONE" if no prefix was
given, and any "dir" variable, like ${datadir} has an embedded ${prefix}
reference that won't be expanded. That said, I did find a better way to
handle this using AM_CONDITIONAL.
>
> I think it would make things easier to read if the logic was all in one
> place here (ie the way it was before), instead of splitting it up?
>
> eg:
>
> #ifdef JAVA_HOME
> SET ("java.home", JAVA_HOME);
> SET ("sun.boot.class.path", ....);
> else
> SET ("java.home", PREFIX);
> ....
>
The AM_CONDITIONAL change allowed me to simplify this even further.
I committed the attached patch to mainline and gcc-4_0-branch.
Tom
2005-04-05 Thomas Fitzsimmons <fitzsim@redhat.com>
* doc/install.texi (Configuration): Document --with-java-home.
2005-04-05 Thomas Fitzsimmons <fitzsim@redhat.com>
PR libgcj/20750
* Makefile.am (AM_CXXFLAGS): Define JAVA_HOME.
* Makefile.in: Regenerate.
* configure.ac: Add --with-java-home option.
* configure: Regenerate.
* external/Makefile.in: Regenerate.
* external/sax/Makefile.in: Regenerate.
* external/w3c_dom/Makefile.in: Regenerate.
* gcj/Makefile.in: Regenerate.
* include/Makefile.in: Regenerate.
* testsuite/Makefile.in: Regenerate.
* java/lang/natRuntime.cc (insertSystemProperties): Set java.home
to JAVA_HOME macro.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: libgcj-java-home-config3.patch
Type: text/x-patch
Size: 19073 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/java-patches/attachments/20050406/5d576f9d/attachment.bin>
More information about the Java-patches
mailing list