PATCH to add -verbose:class flag

Tom Tromey tromey@redhat.com
Mon Jun 28 23:49:00 GMT 2004


>>>>> "Per" == Per Bothner <per@bothner.com> writes:

Per> It is arguable that the declaration of verbose_class_flag should go
Per> into some header file, but I don't know which is preferred.

Could you put it in `namespace gcj'?  We try to avoid globals with
non-gcj-specific names.  Unfortunately we aren't super-consistent
about exactly what names we do choose...

The declaration could go in include/jvm.h (look for "namespace gcj").
The definition can go anywhere, eg where it is is fine.

Per> +  if (verbose_class_flag)
Per> +    fprintf (stderr, "[Loaded %s]\n", (const char*)(name->data));

This is sort of a misnomer since this code is actually only run during
class initialization.  The class might have been loaded long before.
I'm not sure whether that little pedanticism matters?  I didn't look
at what the JDK does.

Tom



More information about the Java-patches mailing list