[gui] [PATCH] Fix Component.reshape()

David Jee djee@redhat.com
Fri Jun 25 17:43:00 GMT 2004


Hello,

I committed the following patch to the java-gui-branch.  It fixes
Component.reshape(), so that a component will repaint the parent and
itself only when it is necessary.  For example, even if the size of the
component has been changed, if the component is not within the visible
bounds of the parent, then there is no point repainting the component.

Also, this patch fixes resize() and move() methods, so that they
delegate to setBounds().  This eliminates some duplicate code in
Component class.

-David Jee

2004-06-25  David Jee  <djee@redhat.com>

        * java/awt/Component.java
        (move): Delegate to setBounds().
        (resize): Likewise.
        (reshape): Fix so it repaints parent and self only when necessary.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: ItemList1.patch
Type: text/x-patch
Size: 3243 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/java-patches/attachments/20040625/327a5eb1/attachment.bin>


More information about the Java-patches mailing list