[patch] boehm-gc remove darwin hack

Boehm, Hans hans_boehm@hp.com
Wed Dec 31 02:20:00 GMT 2003


If I understand this correctly, It makes sense to leave this as is.
(Except that I just added a comment to the upstream source stating
that the __private_extern__ hack is required only for pre-3.4 gcc.)

If I remove it from the upstream source, it breaks when built by itself
with an older gcc.  If we remove it just from the gcc tree, we get a
divergence that's not strictly necessary.  The package already contains lots
of code that's not strictly useful in the gcc tree and is never built in
that context.

Hans


> -----Original Message-----
> From: java-patches-owner@gcc.gnu.org
> [mailto:java-patches-owner@gcc.gnu.org]On Behalf Of Tom Tromey
> Sent: Tuesday, December 23, 2003 10:28 AM
> To: Andreas Tobler
> Cc: gcc-patches; Java Patch List
> Subject: Re: [patch] boehm-gc remove darwin hack
> 
> 
> >>>>> "Andreas" == Andreas Tobler <toa@pop.agri.ch> writes:
> 
> Andreas> Boehm-gc is built by default on darwin from 3.4 on. 
> When 3.4 is
> Andreas> released it contains the fix above and we can build 
> boehm-gc either
> Andreas> with apple gcc or with 'the latest' fsf gcc.
> 
> Andreas> 2003-12-20  Andreas Tobler  <a.tobler@schweiz.ch>
> Andreas> 	* dyn_load.c (GC_register_dynamic_libraries): 
> Remove ifdef
> Andreas> 	conditional for darwin. Fixed by fixinclude now.
> 
> I'd prefer to see this go in upstream first.  They might be reluctant
> to accept it, since older versions of gcc still need it.  I don't
> think this is important enough an issue to warrant a local divergence.
> 
> Tom
> 



More information about the Java-patches mailing list