Michael Koch
Fri Nov 28 17:02:00 GMT 2003

On Fri, Nov 28, 2003 at 10:14:53AM -0600, Mohan Embar wrote:
> Hi Michael,
> >> >To circumvent this timeout I rewrite lookup() to just return when it is asked 
> >> >for "".
> >> 
> >> What do you think of the name "nativeLookup" instead of "lookup0"?
> >
> >The "native" is really redundant. In the java file the "native" keyword
> >is used. This looks really weird to me:
> >If you dont like the "0" can we aggree on "implLookup" or something like
> >that ?
> I did a search for "::native" and "::impl" and I think impl is more
> common. I thought native methods starting with "native" were more
> common then they really are. (I only found java.lang.Runtime.nativeGetLibname
> and - hmm, who wrote that one? :) )

/me looks into the air.

I think have written that with alcohol ...

> FWIW, I think implLookup is fine.
> P.S. I was trying to get natSelectorImplWin32 to work and wrote a cool
> test (no, not a Mauve one yet - I have my fingers in my ears already)
> which unconvered issues with selectors, etc. Do you want:
> - me to investigate this?
> - me to give you the test and you investigate this?
> - both?
> Let me know.

I take door B (send me the test please). Its surely possible that there
are some bugs in the java part of NIO. I can fix them first and then
we/you can implement/submit/commit the native methods for Win32.


More information about the Java-patches mailing list