Mohan Embar
Fri Nov 28 16:14:00 GMT 2003

Hi Michael,

>> >To circumvent this timeout I rewrite lookup() to just return when it is asked 
>> >for "".
>> What do you think of the name "nativeLookup" instead of "lookup0"?
>The "native" is really redundant. In the java file the "native" keyword
>is used. This looks really weird to me:

>If you dont like the "0" can we aggree on "implLookup" or something like
>that ?

I did a search for "::native" and "::impl" and I think impl is more
common. I thought native methods starting with "native" were more
common then they really are. (I only found java.lang.Runtime.nativeGetLibname
and - hmm, who wrote that one? :) )

FWIW, I think implLookup is fine.

P.S. I was trying to get natSelectorImplWin32 to work and wrote a cool
test (no, not a Mauve one yet - I have my fingers in my ears already)
which unconvered issues with selectors, etc. Do you want:

- me to investigate this?
- me to give you the test and you investigate this?
- both?

Let me know.

-- Mohan

More information about the Java-patches mailing list