Patch: Bitmap descriptor GC marking

Tom Tromey
Sun May 7 10:13:00 GMT 2000

Bryce> +  if (klass->vtable->method[1] != ObjectClass.vtable->method[1])

Bryce>  struct _Jv_VTable
Bryce>  {
Bryce>    jclass clas;
Bryce> -  void *method[1];
Bryce> +  void *gc_descr;
Bryce> +  void *method[];
Bryce>  };

These two changes conflict.  This is why finalization doesn't work.

I've really been wanting to make this second change, and get rid of
the magic constant "1" in the first change, for a long time.  But
unfortunately it isn't an entirely trivial change to make.  We have to
There are also pieces in array class creation that need to change.
It's possible there's other code around, which I've convenient
forgotten right now, which has to deal with this stuff too.  Gross.

I think I'd prefer "void *method[0];", as that is a bit clearer to me.

Anyway, I'm definitely in favor of this change -- both the ones above,
and the overall patch you sent.  Hopefully we'll figure out the other
problems soon.


More information about the Java-patches mailing list