[RFC TREE-WIDE] gcc: stop using 'int' to represent sets of qualifiers
Joseph Myers
josmyers@redhat.com
Tue Jun 30 16:21:58 GMT 2026
On Tue, 30 Jun 2026, Arsen Arsenović wrote:
> Then, maybe, making 'includes_p' (the predicate that was checking
> whether QS1 includes all qualifiers of QS2) actually be called
> usable_as_p or such, and having it reject TYPE_QUAL_ATOMIC differences
> makes sense? (I'd prefer a better name, because 'usable as' sounds like
> it implies a NOP_EXPR suffices for conversion, but that may not be true
> due to address spaces, but I'm coming up blank)
>
> Given this special nature of TYPE_QUAL_ATOMIC, I'm not sure in which
> cases it would be applicable to have a "pure" includes predicate.
>
> What do you think?
I'd expect cases for C that check such a predicate generally to be
concerned with access qualifiers (and thus already exclude
TYPE_QUAL_ATOMIC), but the question is what the code currently does (if
the refactoring shows up bugs, fixing those bugs would best be done
separately from the refactoring).
--
Joseph S. Myers
josmyers@redhat.com
More information about the Gcc
mailing list