Last call for bikeshedding on attribute sym/exalias/reverse_alias
Jonathan Wakely
jwakely.gcc@gmail.com
Fri Sep 8 07:34:33 GMT 2023
On Fri, 8 Sept 2023, 06:58 Dave Blanchard, <dave@killthe.net> wrote:
> On Fri, 08 Sep 2023 02:25:38 -0300
> Alexandre Oliva via Gcc <gcc@gcc.gnu.org> wrote:
>
> > Attribute sym, named after symver, is the one in the latest version of
> > the patch. mnemonic_alias, convenience_alias and asm_alias are other
> > possibilities that comes to mind. The 2020-August thread has many more.
>
> Sounds like a useful feature. Since it specifically deals with C++ name
> mangling, how about 'demangle'?
>
It doesn't demangle though, it provides an alternative mangled name.
> C++ is an abomination and name mangling is a perfect example of the brain
> damage surrounding this abortion of a language, but I digress...
>
More information about the Gcc
mailing list