Minimum CUDA version supported by GCC?

Jakub Jelinek jakub@redhat.com
Thu Nov 19 11:18:35 GMT 2020


On Thu, Nov 19, 2020 at 12:03:09PM +0100, Thomas Schwinge wrote:
> As far as I can tell, we (GCC) don't currently state the minimum CUDA
> version supported: for nvptx target, and especially then for
> OpenACC/OpenMP nvptx offloading.
> <https://gcc.gnu.org/install/specific.html#nvptx-x-none>,
> <https://gcc.gnu.org/wiki/nvptx>, <https://gcc.gnu.org/wiki/Offloading>
> all are silent on this topic, for example.
> 
> Do distribution maintainers have an opinion on this maybe, what they need
> to support (for upcoming GCC 11, especially)?  (Matthias, others?)

I think it would be nice not to kill support for older devices
unnecessarily.  If there is a strong reason, sure.  And ditto for older
CUDA versions.
But I'm afraid many people have older HW and don't have anything newer.

I'm testing offloading only from time to time, but the only remaining hw
I have has 3.5 capability (Quadro K6000, GK110GL core).  And I use that for
both upstream development and distro offloading testing.

	Jakub



More information about the Gcc mailing list