Support Library Requirements for GCC 10

Richard Biener richard.guenther@gmail.com
Tue Jan 7 12:40:00 GMT 2020


On Tue, Jan 7, 2020 at 1:38 PM Richard Biener
<richard.guenther@gmail.com> wrote:
>
> On Sun, Jan 5, 2020 at 9:28 PM Bruno Haible <bruno@clisp.org> wrote:
> >
> > Hi,
> >
> > The minimum support library version of MPC for building GCC 10 is not
> > correct.
> >
> > After downloading gcc-10-20191229.tar.xz and
> >   $ cd gcc-10-20191229/gcc/doc
> >   $ ./install.texi2html
> >   $ xdg-open HTML/prerequisites.html
> > I installed
> >   - gmp 4.3.2 - works,
> >   - mpfr 3.1.0 - works,
> >   - mpc 0.8.1 - fails!
> >
> > The failure has been reported already in [1]. The fix is to use
> >
> >   - mpc 1.0.3 - works.
>
> Indeed.  I checked 0.8.2 and it doesn't work, I checked 1.0.1 and that does
> so I adjusted it to 1.0.1 or later.

Note that in-tree builds are only supported for exactly the versions that
./download_prerequesites download but the minimal documented versions
are those that are known to work when the library is compiled and installed
separately.

Richard.

> Richard.
>
> > This wastes some time for everyone who attempts to install GCC 10 from
> > scratch.
> >
> > In [2] it was suggested to look in the contrib/download_prerequisites script.
> > This script indeed contains
> >
> >   mpc='mpc-1.0.3.tar.gz'
> >
> > Additionally, the mpc-0.8.1 release is so old that it is not (or no longer)
> > on ftp.gnu.org [3].
> >
> > Therefore I would suggest
> >   1) to change the documentation (HTML/prerequisites.html) in the GCC 10
> >      snapshots to mention mpc-1.0.3 instead of mpc-0.8.1,
> >   2) likewise, change https://gcc.gnu.org/install/prerequisites.html
> >      to mention mpc-1.0.3 instead of mpc-0.8.1.
> >
> > Bruno
> >
> > [1] https://gcc.gnu.org/ml/gcc/2017-05/msg00022.html
> > [2] https://gcc.gnu.org/ml/gcc/2017-05/msg00024.html
> > [3] https://ftp.gnu.org/gnu/mpc/
> >



More information about the Gcc mailing list