Wabi warnings during GCC build

Steve Ellcey sellcey@cavium.com
Wed Jun 27 16:09:00 GMT 2018


Are other people building GCC seeing these messages during the build:

cc1plus: warning: -Wabi won't warn about anything [-Wabi]
cc1plus: note: -Wabi warns about differences from the most up-to-date ABI, which is also used by default
cc1plus: note: use e.g. -Wabi=11 to warn about changes from GCC 7

It doesn't seem to be causing any problems in the build (even bootstrap)
but I am wondering why it is there.  It seems to be happening when
using the latest (just built) g++ to build libstdc++ so it shouldn't
be related to the system GCC that I am using to build with.

I didn't find any mention of it in the gcc or libstdc++ mailing lists
when I looked or find any bugzilla report.

Steve Ellcey



More information about the Gcc mailing list