can we rename vec<>.safe_push() to vec<>.push()?
Aldy Hernandez
aldyh@redhat.com
Thu Aug 31 11:49:00 GMT 2017
So.... ok to default to a lazy one, or are suggesting we leave things
as they are?
Aldy
On Thu, Aug 31, 2017 at 7:38 AM, Richard Biener
<richard.guenther@gmail.com> wrote:
> On Thu, Aug 31, 2017 at 1:31 PM, Aldy Hernandez <aldyh@redhat.com> wrote:
>> I understand the need for .quick_push(), when we know the size of the
>> allocated elements before hand, but do we really need to call the
>> common variant safe_push? Can't we just call it push()?
>>
>> Or is there some magic C++ rule/idiom that prohibits us from doing this?
>>
>> I volunteer to provide a patch if y'all agree.
>
> I think having quick_push and safe_push makes you think which one to use
> while push would be the obvious lazy one. Aka nobody thinks of pre-allocating
> stuff and using quick_push anymore.
>
> Just my 2 cents...
>
> Richard.
>
>> Aldy
More information about the Gcc
mailing list