can we rename vec<>.safe_push() to vec<>.push()?

Aldy Hernandez aldyh@redhat.com
Thu Aug 31 11:38:00 GMT 2017


I understand the need for .quick_push(), when we know the size of the
allocated elements before hand, but do we really need to call the
common variant safe_push?  Can't we just call it push()?

Or is there some magic C++ rule/idiom that prohibits us from doing this?

I volunteer to provide a patch if y'all agree.

Aldy



More information about the Gcc mailing list