An internal GCC compiler error when compiling GCC 7.x with GCC 6.x and 4.x

Joseph Myers joseph@codesourcery.com
Mon Aug 7 15:03:00 GMT 2017


On Mon, 7 Aug 2017, Martin Liška wrote:

> On 07/30/2017 05:08 AM, Ethin Probst wrote:

> > --enable-checking=all --disable-nls --enable-fixed-point

> > In file included from ../../../gcc-7.1.0/libgcc/fixed-bit.c:55:0:
> > ../../../gcc-7.1.0/libgcc/fixed-bit.h:64:1: error: unable to emulate 'QQ'

> I can take a look, but please create a bug issue and try to isolate *.i* 
> files by adding -E to the GCC invocation that causes the problem.

I think it's clear enough from the above that the problem is the use of 
--enable-fixed-point for a target that doesn't support that feature (i.e. 
anmything other than ARM and MIPS).

(As I previously noted 
<https://gcc.gnu.org/ml/gcc-patches/2011-05/msg00846.html> it's 
unfortunate that the fixed-point support requires so much target-specific 
code rather than being based on GIMPLE lowering.  But as that's the 
present situation, --enable-fixed-point on targets without the 
target-specific code isn't really useful.)

-- 
Joseph S. Myers
joseph@codesourcery.com


More information about the Gcc mailing list