[ping] Re: proper name of i386/x86-64/etc targets
H.J. Lu
hjl.tools@gmail.com
Tue Jan 20 13:02:00 GMT 2015
On Mon, Jan 19, 2015 at 11:31 PM, Uros Bizjak <ubizjak@gmail.com> wrote:
> On Tue, Jan 20, 2015 at 3:26 AM, Sandra Loosemore
> <sandra@codesourcery.com> wrote:
>
>>> I've noticed that the GCC user documentation is quite inconsistent about
>>> the name(s) it uses for i386/x86-64/etc targets. invoke.texi has a
>>> section for "i386 and x86-64 Options", but in other places the manual
>>> uses x86, X86, i?86, i[34567]86, x86_64 (underscore instead of a dash),
>>> etc.
>>>
>>> I'd be happy to work on a patch to bring the manual to using a common
>>> naming convention, but what should it be? Wikipedia seems to use "x86"
>>> (lowercase) to refer to the entire family of architectures (including
>>> the original 16-bit variants), "IA-32" for the 32-bit architecture (I
>>> believe that is Intel's official name), and "x86-64" (with a dash
>>> instead of underscore) for the 64-bit architecture. But of course the
>>> target maintainers should have the final say on what names to use.
I like this suggestion. Thanks.
>>
>> Ping? Any thoughts?
>
> Let's ask Intel people ...
>
--
H.J.
More information about the Gcc
mailing list