libgomp: "GNU OpenMP Runtime Library" (was: [PATCH 1/5] OpenACC 2.0 support for libgomp - OpenACC runtime, NVidia PTX/CUDA plugin (repost))

Thomas Schwinge thomas@codesourcery.com
Wed Nov 12 11:18:00 GMT 2014


Hi!

On Wed, 12 Nov 2014 11:06:26 +0100, Jakub Jelinek <jakub@redhat.com> wrote:
> On Tue, Nov 11, 2014 at 01:53:23PM +0000, Julian Brown wrote:
> > --- a/libgomp/configure.ac
> > +++ b/libgomp/configure.ac
> > @@ -2,6 +2,8 @@
> >  # aclocal -I ../config && autoconf && autoheader && automake
> >  
> >  AC_PREREQ(2.64)
> > +#TODO: Update for OpenACC?  But then also have to update copyright notices in
> > +#all source files...
| >  AC_INIT([GNU OpenMP Runtime Library], 1.0,,[libgomp])
> 
> Please drop this.

(I agree to drop the TODO marker, obviously.)  Note that I'm not trying
to drive this into a "bikeshedding" discussion, and neither is my
intention to discredit the lots of pioneering OpenMP work in GCC (which
we're largely basing our OpenACC work on -- thanks!).

The underlying question here is, with offloading generally as well as the
OpenACC Runtime Library also to be living in libgomp, calling it "GNU
OpenMP Runtime Library" is no longer accurate.  (Also, I'm not proposing
to change the libgomp library name -- that would probably be too much of
a hassle?)  Do we want a new "verbose" name for libgomp, "GNU Offloading,
OpenACC, and OpenMP Runtime Library" (sorting alphabetically), or
something else, or no change.  I'm afraid that not changing it will be
confusing to users who are looking for the GCC implementation of the
OpenACC Runtime Library, for example?


Grüße,
 Thomas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 472 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc/attachments/20141112/84bd5914/attachment.sig>


More information about the Gcc mailing list