[gimple-classes, committed 4/6] tree-ssa-tail-merge.c: Use gassign
Marek Polacek
polacek@redhat.com
Sat Nov 8 10:13:00 GMT 2014
On Fri, Nov 07, 2014 at 10:01:45PM +0100, Richard Biener wrote:
> Just a comment as these patches flow by - I think this is a huge step
> backwards from "enforcing" s1/s2 being a gimple_assign inside
> gimple_assign_rhs1 to this as_a <gassign *> boilerplate at _each_ callsite!
FWIW, I feel the same way. More to type, worse readability, a lot
more of line-wrapping.
Sorry,
Marek
More information about the Gcc
mailing list