[GSoC] How to get started with the isl code generation

Roman Gareev gareevroman@gmail.com
Sun Jun 8 17:43:00 GMT 2014


Hi Tobias,

> This file is empty. It seems to be the perfect place for gloog_isl,
> maybe give it a more descriptive name. E.g.,
>
> graphite_regenerate_ast_isl()
>
> We could then rename gloog, to graphite_regenerate_ast_cloog().
>
> gloog comes from graphite + cloog and does not make sense in the context
> of isl.

Would it be better to rename gloog in a separate patch (because it
could cause renaming of gloog_error, for eaxmple, and increase the
size of the patch)?

I tried to incorporate all your comments in the following patch. I
also attach the change log to this message.

--
                                   Cheers, Roman Gareev
-------------- next part --------------
A non-text attachment was scrubbed...
Name: patch
Type: application/octet-stream
Size: 10211 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc/attachments/20140608/ec364f6a/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ChangeLog_entry
Type: application/octet-stream
Size: 781 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc/attachments/20140608/ec364f6a/attachment-0001.obj>


More information about the Gcc mailing list