Normalizing the bitmap APIs.
Diego Novillo
dnovillo@google.com
Thu Oct 11 21:57:00 GMT 2012
On 2012-10-11 16:25 , Lawrence Crowl wrote:
> On 10/11/12, Diego Novillo <dnovillo@google.com> wrote:
>> On 2012-10-11 13:26 , Lawrence Crowl wrote:
>>> My only other concern was that the mapping between those function
>>> names and the tasks to be done sometimes seemed less than obvious.
>>> So, I proposed the name change. However, I think the current names
>>> are workable, assuming an acceptable solution to the above problem.
>>
>> I would say, add both variants and make the empty ones drop the return
>> value. So, for instance, bitmap_ior returns a value, so make
>> bitmap_ior_cg drop it.
>
> That convention is opposite from what is used in sbitmap, where _cg
> indicates that it returns the bool. I think returning the value
> will be the less common case.
Sorry, I mixed the two up. I meant the version that makes sense.
Diego.
More information about the Gcc
mailing list