Normalizing the bitmap APIs.
Diego Novillo
dnovillo@google.com
Thu Oct 11 19:16:00 GMT 2012
On 2012-10-11 13:26 , Lawrence Crowl wrote:
> My only other concern was that the mapping between those function
> names and the tasks to be done sometimes seemed less than obvious.
> So, I proposed the name change. However, I think the current names
> are workable, assuming an acceptable solution to the above problem.
I would say, add both variants and make the empty ones drop the return
value. So, for instance, bitmap_ior returns a value, so make
bitmap_ior_cg drop it.
Diego.
More information about the Gcc
mailing list