symbol_refs vs. eq_attr in define_insn_reservations
Richard Sandiford
rdsandiford@googlemail.com
Thu Feb 16 19:55:00 GMT 2012
Quentin Neill <quentin.neill.gnu@gmail.com> writes:
> Hi,
>
> For readability (and correctness) I'm interested in rewriting a bunch of:
>
> (define_insn_reservation "insn1" 0 (eq_attr "attr1" "val1,val2"))
>
> into something like:
>
> (define attr "consattr1" "val1,val2"
> (const (cond [
> (eq_attr "attr1" "val1") (const_string "cvaly")
> (eq_attr "attr1" "val2") (const_string "cvaly")]
> (const_string "cvaln"))))
>
> (define_insn_reservation "insn1" 0 (eq_attr "consattr1" "cval"))
The general idea should work, but I don't think the (cond ...)
should be wrapped in a (const ...)
Richard
More information about the Gcc
mailing list