gnat cross compilation

Arnaud Charlet charlet@adacore.com
Thu Oct 27 08:45:00 GMT 2011


> 	Is it possible to compile a gnat cross compiler based on gcc 4.5.2 using my
> 	pre-installed gnat native compiler based on gcc 3.4.6 ? Or should I try to
> 	build my own local native compiler based on gcc 4.5.2 ?

You needed a matching native compiler first in order to build a cross GNAT
compiler.

So yes, you need to first build a native GCC 4.5.2 in order to build a cross
4.5.2 compiler.

Arno



More information about the Gcc mailing list