RFC: semi-automatic hookization
Joern Rennecke
amylaar@spamcop.net
Tue Nov 16 22:53:00 GMT 2010
Quoting Ian Lance Taylor <iant@google.com>:
> Joern Rennecke <amylaar@spamcop.net> writes:
>
>> Before I go and make all these target changes & test them, is there at
>> least agreemwent that this is the right approach, i.e replacing
>> CUMULATIVE_ARG *
>> with void *, and splitting up x_rtl into two variables.
>
> I don't know how we want to get there, but it seems to me that the place
> we want to end up is with the target hooks defined to take an argument
> of type struct cumulative_args * (or a better name if we can think of
> one). We could consider moving the struct definition into CPU.c, and
> having the target structure just report the size, or perhaps a combined
> allocation/INIT_CUMULATIVE_ARGS function.
>
> Ian
>
More information about the Gcc
mailing list