compile problems with gcc 4.5.0

Jonathan Wakely jwakely.gcc@gmail.com
Mon May 3 12:43:00 GMT 2010


On 3 May 2010 10:43, Klaus Rudolph wrote:
> Hi all,
>
> I tried to compile the gcc 4.5.0 version, but got errors with gmp :-(

Hi,
this question is not appropriate on this mailing list, which is for
discussing development of gcc, please take any further questions about
building or using gcc to the gcc-help mailing list, thanks.

> I did:
>
>
> krud@mauersegler:~/work/gcc-4.5.0$ cp -pr ../gmp-5.0.1/ ./gmp
> krud@mauersegler:~/work/gcc-4.5.0$ cp -pr ../mpfr-2.4.2/ ./mpfr
> krud@mauersegler:~/work/gcc-4.5.0$ cp -pr ../mpc-0.8.1/ ./mpc
> krud@mauersegler:~/work/gcc-4.5.0$ cp -pr ../ppl-0.10.2/ ./ppl

You don't need to copy the sources, a symlink will do.

> krud@mauersegler:~/work/gcc-4.5.0$ mkdir build_linux
> krud@mauersegler:~/work/gcc-4.5.0$ cd build_linux/
> krud@mauersegler:~/work/gcc-4.5.0/build_linux$ ../configure --prefix=/opt/linux --enable-languages=c,c++

See http://gcc.gnu.org/install/configure.html
Building in a sub-directory of the source directory is not supported.

Jonathan



More information about the Gcc mailing list