two more build results for gcc 4.3.2

Joe Buck Joe.Buck@synopsys.COM
Thu Sep 4 20:14:00 GMT 2008


On Thu, Sep 04, 2008 at 11:12:59AM -0700, Joe Buck wrote:
> > I also found an ia64 box running Red Hat Advanced Workstation 2.1.
> > Yes, I know, really old, but I can't change it.  I tried a build...
> > but the bootstrap died.

On Thu, Sep 04, 2008 at 11:37:47AM -0700, Joe Buck wrote:
> I think the issue was that the --with-gmp and --with-mpfr directories
> weren't in LD_LIBRARY_PATH.  I'm re-trying.  If that's the issue,
> I think that it should automatically be taken care of; the configure
> process can determine that it's picking up shared libraries that
> aren't on the default path and make sure that things work anyway.

So I tried that, and it didn't help.  It dies with

mkdir -p -- ia64-unknown-linux-gnu/libgcc
Checking multilib configuration for libgcc...
Configuring stage 1 in ia64-unknown-linux-gnu/libgcc
configure: creating cache ./config.cache
checking for --enable-version-specific-runtime-libs... no
checking for a BSD-compatible install... /usr/bin/install -c
checking for gawk... gawk
checking build system type... ia64-unknown-linux-gnu
checking host system type... ia64-unknown-linux-gnu
checking for ia64-unknown-linux-gnu-ar... ar
checking for ia64-unknown-linux-gnu-lipo... lipo
checking for ia64-unknown-linux-gnu-nm... /remote/atg5/jbuck/gcc-4.3.2-ia64build/./gcc/nm
checking for ia64-unknown-linux-gnu-ranlib... ranlib
checking for ia64-unknown-linux-gnu-strip... strip
checking whether ln -s works... yes
checking for ia64-unknown-linux-gnu-gcc... /remote/atg5/jbuck/gcc-4.3.2-ia64build/./gcc/xgcc -B/remote/atg5/jbuck/gcc-4.3.2-ia64build/./gcc/ -B/u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/bin/ -B/u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/lib/ -isystem /u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/include -isystem /u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/sys-include
checking for suffix of object files... configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.

But ia64-unknown-linux-gnu/libgcc/config.log doesn't have any useful
details.  It has

CC='/remote/atg5/jbuck/gcc-4.3.2-ia64build/./gcc/xgcc -B/remote/atg5/jbuck/gcc-4.3.2-ia64build/./gcc/ -B/u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/bin/ -B/u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/lib/ -isystem /u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/include -isystem /u/jbuck/cvs.ia64/4.3.2/ia64-unknown-linux-gnu/sys-include'

and ends with

-------------
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME "GNU C Runtime Library"
#define PACKAGE_STRING "GNU C Runtime Library 1.0"
#define PACKAGE_TARNAME "libgcc"
#define PACKAGE_VERSION "1.0"

configure: exit 1
-------------

and the "exit 1" is the only sign that something is wrong.




More information about the Gcc mailing list