API for callgraph and IPA passes for whole program optimization
Diego Novillo
dnovillo@google.com
Wed Mar 12 05:56:00 GMT 2008
On 3/9/08 7:26 AM, Jan Hubicka wrote:
> compensate testsuite and documentation for the removal of RTL dump
> letters so I would rather do that just once. Does this seem OK?
Yup, thanks for doing this.
> The patch include the read/write methods that will be just placeholders
> on mainline. Naturally I can remove them for time being at least as
> long as we think the RTL_PASS/TREE_PASS macros are good idea.
Nitpick on the name, can you s/TREE/GIMPLE/?
> quite easilly see that those are stepping back from plan not making
> passmanager poluted by ugly macros, but on the other hand since the PM
> is now doing RTL/IPA/tree passes it needs at least a little of
> flexibility to be able update API of one without affecting others.
How about doing the simple hierarchy as you outlined in your last
message? Both gimple and rtl passes would inherit everything from base,
and ipa would have the additional hooks for summary generation and whatnot.
Diego.
More information about the Gcc
mailing list