Changes in C++ FE regarding pedwarns to be errors are harmful
Manuel López-Ibáñez
lopezibanez@gmail.com
Sat Jan 12 19:50:00 GMT 2008
On 12/01/2008, Jonathan Wakely <jwakely.gcc@gmail.com> wrote:
> On 11/01/2008, Mark Mitchell wrote:
> >
> > Exactly so. I think that we have two kinds of pedwarns: those that are
> > pedantic in the sense we use for C (like, that there cannot be a naked
> > semicolon at the top-level of a file, or that "long long" is not in
> > C++98) and those that refer to semantically reasonable constructs that
> > we previously accepted, often because they were allowed by cfront or the
> > ARM. With flag_permissive, we probably want the latter category to be
> > warnings at most; without flag_permissive, we want them to be errors.
>
> I'll start the ball rolling with cp/call.c, cp/class.c and cp/cvt.c
> I'll call the latter category isowarns for the purpose of this mail,
> they are technically illegal constructs that are errors without
> -fpermissive. My suggestion of pedwarn/isowarn given in capitals on
> each entry.
>
Here is an initial patch implementing some of your proposals. I used
pederror as the name of the function. That is, it is an error unless
fpermissive is given.
Let me know your opinion. (Not bootstrapped, not tested, not complete patch).
Cheers,
Manuel.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pederror.diff
Type: text/x-diff
Size: 11649 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc/attachments/20080112/58305035/attachment.bin>
More information about the Gcc
mailing list