I have often been confused with the 'GS' prefix we have throughout the API. It's confusing as we seem to have two different things (GS and GIMPLE). I would like to propose that we rename all the 'gs' and 'GS' prefixes to 'GIMPLE'. That would mean renaming files, data structures and variables. Any objections?