no_new_pseudos

Dave Korn dave.korn@artimi.com
Wed Jul 4 18:41:00 GMT 2007


On 04 July 2007 19:25, Alexandre Oliva wrote:

> Actually, how about replacing the three variables with a single
> tri-state variable that indicates the progress into reload:
> 
> enum { BEFORE_RELOAD = -1, DURING_RELOAD = 0, AFTER_RELOAD = 1 }
> reload_status; 
> 
> #define BEFORE_RELOAD_P() (reload_status < DURING_RELOAD)
> #define DURING_RELOAD_P() (reload_status == DURING_RELOAD)
> #define AFTER_RELOAD_P() (reload_status > DURING_RELOAD)

  That seems quite elegant to me.

    cheers,
      DaveK
-- 
Can't think of a witty .sigline today....



More information about the Gcc mailing list