Renaming build_function_call_expr?
Volker Reichelt
reichelt@igpm.rwth-aachen.de
Tue Dec 6 13:50:00 GMT 2005
Hi,
back in August I removed a call to fold after build_function_call_expr,
since build_function_call_expr already does the folding. In a follow-up
mail Richard Guenther raised the following point
( see http://gcc.gnu.org/ml/gcc-patches/2005-08/msg01466.html ):
> Following precedence and to avoid such issue in future should we rename
> this to fold_build_function_call_expr? Or build_fold_function_call_expr.
The problem is that there are about 113 occurrences of
build_function_call_expr in the GCC tree. I wonder whether
renaming them would be a too big change with too little benefit.
Would it be more appropriate to just change the comment on top of the
function (in builtins.c, line ~8760) from
/* Conveniently construct a function call expression. */
to
/* Conveniently construct and fold a function call expression. */
?
Any preferences?
Regards,
Volker
More information about the Gcc
mailing list