Problem with peephole to peephole2 conversion
Ashwin Kolhe
ashwin.kolhe@gmail.com
Thu Aug 25 13:19:00 GMT 2005
On 8/25/05, Paolo Bonzini <paolo.bonzini@lu.unisi.ch> wrote:
> I consider this to be less readable than the peep2 way to do it,
> especially if your peephole2 had three or four instructions. And
> peep2_regno_dead_p uses an array (a circular buffer) so it's more
> efficient. Indeed dead_or_set_p even has a loop inside it.
>
> Paolo
Thanks a lot for ur help. can u give me a pointer to the origin of
peep2_reg_dead_p?
Regards,
Ashwin
More information about the Gcc
mailing list