Difference between {expand,fold,simplify}_builtin_foo ???

Jeffrey A Law law@redhat.com
Tue Sep 21 07:53:00 GMT 2004


On Mon, 2004-09-20 at 12:45, Kaveh R. Ghazi wrote:
>  > The key difference between them is the simplify_ variant is not
>  > allowed to generate RTL nor create non-gimple code.
>  > jeff
> 
> Ok thanks, that explains expand_builtin_* vs. simplify_builtin_*.
> 
> However what about fold_builtin_*?  Both fold_builin_* and
> simplify_builtin_* return trees.  Are the fold_ variants allowed to
> produce non-gimple?  Or are fold_builtin_* and simplify_builtin_*
> really the same and we should canonicalize the naming convention?
I didn't realize we had a 3rd routine.  Ugh.  I don't know which is
preferred.  Sigh.

jeff




More information about the Gcc mailing list