Difference between {expand,fold,simplify}_builtin_foo ???

Eric Christopher echristo@redhat.com
Mon Sep 20 18:38:00 GMT 2004


On Mon, 2004-09-20 at 10:41, Kaveh R. Ghazi wrote:
> I've been out of GCC most of the summer, so I don't know if this was
> discussed or not.  I was wondering what's the reason for and
> difference between {expand,fold,simplify}_builtin_foo().
> 
> Looking at e.g. expand_builtin_sprintf and simplify_builtin_sprintf,
> they seem to do exactly the same transformations.  Can we just have
> expand_builtin_sprintf call simplify_builtin_sprintf and then expand
> the result?  This would remove lots of code duplication and potential
> locations of errors.

I've got a patch in the works that removes most of the simplify_*
routines. Some of them I've uh... folded... into fold_* and others I'm
doing what you said here. :)

I'll probably get back to it later today :)

-eric

-- 
Eric Christopher <echristo@redhat.com>



More information about the Gcc mailing list