wording of ICE comment (was "Re: committed: gigi clean ups")
Richard Kenner
kenner@vlsi1.ultra.nyu.edu
Wed Oct 6 14:57:00 GMT 2004
> > /* This abort means the entity "gnat_entity" has an incorrect scope,
> > i.e. that its scope does not correspond to the subprogram in which
> > it is declared */
> > - abort ();
> > + gcc_unreachable ();
>
> Perhaps this comment could be updated as well.
Agreed. Richard, could you put that on your list ?
Actually, I'm not sure what the issue is. Is it the use of "this abort"?
If so, I thought about that at the time and believed that "this abort" is a
reasonable terminology for the situation and means the English word "abort"
rather than specifically referring to the function "abort". I felt that
saying "this call to gcc_unreachable" is needlessly verbose.
But we should have a common convention for the wording, so I thought I'd
raise the issue here.
More information about the Gcc
mailing list