Marek Peteraj wrote: Are there any plans to change this? The example i've mentioned in my previous mail seems much more readable than a printf() style inline asm. It would also make porting much more simple and painless. Definitely sounds useful. Perhaps you should try to make this improvement yourself! I don't know of anyone else interested in working on this. Marek