PROPOSAL: targetm.expand_tree_builtin hook

Richard Henderson
Tue May 11 16:37:00 GMT 2004

> The only nit I have is with the name 'expand_overloaded_builtin', since
> overloading is neither a necessary nor a sufficient condition for using 
> the hook. :-)

Actually, I would think it is.  The only reason for this hook and its
placement is to be able to fiddle the return type of the builtin.
Changing types means "overloading" to me.  If you're not going to be
changing types, perhaps you want a different hook.

> Aside from that, I think it would be great if you could commit
> this functionality!  Can you? :-)

I'm certainly not going to commit the whole patch.


More information about the Gcc mailing list