make sure struct real_value's bitfields are packed
Richard Henderson
rth@redhat.com
Wed Mar 24 10:51:00 GMT 2004
On Sun, Mar 21, 2004 at 02:00:43PM -0300, Alexandre Oliva wrote:
> * real.h (struct real_value): Use the same type for all
> bitfields. Rename exp to uexp.
> (REAL_EXP, SET_REAL_EXP): New accessor macros for uexp.
> Adjust all uses of exp...
> * builtins.c: ... here, ...
> * emit-rtl.c: ... here, and ...
> * real.c: ... and here.
Ug. Ok I guess. For the record, what ABI cares about this?
And does it *really* care about signed vs unsigned int? Not
just the enum thing?
r~
More information about the Gcc
mailing list