[lno] [RFC] if-conversion and auto vectorizer

Chris Lattner sabre@nondot.org
Tue Mar 16 03:46:00 GMT 2004


Richard Henderson wrote:
> This mere fact might argue for the creation of a boolean temporary for
> the comparison.

FWIW, this is exactly what we do in LLVM (all binary branches and select
instructions require a boolean argument, not a conditional).  Also,
amusingly we have a select instruction that acts exactly as was described
and even has the same name, though I do know you chose to use "COND_EXPR"
as the name in the end.

-Chris

-- 
http://llvm.cs.uiuc.edu/
http://www.nondot.org/~sabre/Projects/



More information about the Gcc mailing list