[libobjc] May I tweak objc-api.h?

Nicola Pero nicola@brainstorm.co.uk
Fri Feb 6 23:59:00 GMT 2004


> >>> Again: What do you propose that code should do to work with both
> >>> versions?
> >>
> >> If you rename 'class' to 'super_class' and reference it as
> >> 'super_class',
> >> then this will work in all four of our C flavors, so I'm not sure I
> >> understand
> >> your question...  Or are you suggesting that we do something like
> >>
> >>    #ifdef __cplusplus
> >>      Class super_class;
> >>    #else
> >>      Class class;
> >>    #endif
> >>
> >> ?  While possible, I'd submit that this approach will be more 
> >> confusing
> >> in the long run.
> >
> > Yes - it would be messy and confusing.  Why don't you just rename it and
> > increase the ObjC runtime version number ?

Why ?  That is what it is there for :-)



More information about the Gcc mailing list