Bootstrap Failure on i686-pc-linux-gnu

Mikael Kilpeläinen mikael.kilpelainen@kolumbus.fi
Wed Dec 1 13:11:00 GMT 2004


Hi.

Speaking of bootstrap failures, I have one :)
I have been getting this particular error for some time now:

stage1/xgcc -Bstage1/ -B/usr/local/i686-pc-linux-gnu/bin/   -O2 -g 
-fomit-frame-pointer -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes 
-Wmissing-prototypes -pedantic -Wno-long-long -Wno-variadic-macros 
-Wold-style-definition -Werror -fno-common   -DHAVE_CONFIG_H    -I. -I. 
-I../../gcc/gcc -I../../gcc/gcc/. -I../../gcc/gcc/../include 
-I../../gcc/gcc/../libcpp/include  \
  -DTARGET_NAME=\"i686-pc-linux-gnu\" \
  -c ../../gcc/gcc/toplev.c -o toplev.o
../../gcc/gcc/toplev.c: In function 'toplev_main':
../../gcc/gcc/toplev.c:544: sorry, unimplemented: inlining failed in call to 
'floor_log2': redefined extern inline functions are not considered for 
inlining
../../gcc/gcc/toplev.c:1675: sorry, unimplemented: called from here
../../gcc/gcc/toplev.c:544: sorry, unimplemented: inlining failed in call to 
'floor_log2': redefined extern inline functions are not considered for 
inlining
../../gcc/gcc/toplev.c:1679: sorry, unimplemented: called from here
../../gcc/gcc/toplev.c:544: sorry, unimplemented: inlining failed in call to 
'floor_log2': redefined extern inline functions are not considered for 
inlining
../../gcc/gcc/toplev.c:1681: sorry, unimplemented: called from here
../../gcc/gcc/toplev.c:544: sorry, unimplemented: inlining failed in call to 
'floor_log2': redefined extern inline functions are not considered for 
inlining
../../gcc/gcc/toplev.c:1685: sorry, unimplemented: called from here
make[2]: *** [toplev.o] Error 1


I am trying with

env CC='gcc-3.4.2' ../gcc/configure --enable-languages=c++,c,java 
--enable-threads=posix
make bootstrap

and (if it makes any difference) in Mandrake 10

$ g++-3.4.2 -v
Reading specs from /usr/local/lib/gcc/i686-pc-linux-gnu/3.4.2/specs
Configured with: ../gcc-3.4.2/configure --enable-languages=c++,c 
--enable-threads=posix --program-suffix=-3.4.2 
--enable-version-specific-runtime-libs
Thread model: posix
gcc version 3.4.2


I wonder if this is a bug or could there be some other reasons?


Mikael



More information about the Gcc mailing list