libcpp's aclocal.m4 regeneration question. Also is it time for a toplevel "m4" directory?

Joseph S. Myers jsm@polyomino.org.uk
Mon Aug 23 14:58:00 GMT 2004


On Mon, 23 Aug 2004, Kelley Cook wrote:

> Also now that we are moving to automake 1.9, shouldn't we be split out all the
> extra macros we use into individual files within a toplevel m4 directory as
> the automake people recommend?  The generated aclocal and configure would

Probably.  There are some .m4 files in config/ but some contain many 
macros each.  In addition, they are rather inconsistent about macro naming 
conventions, using

AC_
CYG_AC_
GCC_
ACX_
NCN_
ZW_
AM_

Except for those copied from other GNU packages or overriding standard 
autoconf/automake macros, a standard naming convention such as GCC_AC_ 
should be used.  And some macros should perhaps be contributed back to GNU 
autoconf.  And some are probably obsolete with autoconf 2.59.  This is all 
good for incremental cleanup a macro at a time, but some bits may be 
easier once src too is converted to autoconf 2.59.

Note also the statement in intl/README:

* aclocal.m4 was constructed following the instructions printed by
  "gettextize" from the files that gettext 0.12.1 installs in
  $(prefix)/share/aclocal.

(so intl/aclocal.m4 was generated with aclocal 1.4-p6).

-- 
Joseph S. Myers               http://www.srcf.ucam.org/~jsm28/gcc/
    jsm@polyomino.org.uk (personal mail)
    jsm28@gcc.gnu.org (Bugzilla assignments and CCs)



More information about the Gcc mailing list