versioning of _Unwind_*() symbols
Mark Mitchell
mark@codesourcery.com
Thu Apr 22 21:39:00 GMT 2004
David Mosberger wrote:
>>>>>>On Thu, 22 Apr 2004 09:36:36 -0700, Mark Mitchell <mark@codesourcery.com> said:
>>>>>>
>>>>>>
>
> Mark> However, we shouldn't call this the unwind library. In addition to
> Mark> unwinding routines, it contains things operator new/delete and
> Mark> __cxa_dynamic_cast. Let's call it the ABI library.
>
>As long as the "ABI library" may consist of a separate unwind-library,
>I'm OK with that.
>
Yes, I think that's OK. The ABI library should be called "libcxa.so",
and linking against it must satisfy requests for unwind symbols, but if
that's because libcxa.so pulls in other libraries, that's OK.
--
Mark Mitchell
CodeSourcery, LLC
(916) 791-8304
mark@codesourcery.com
More information about the Gcc
mailing list