CLASS_CANNOT_CHANGE_MODE and CANNOT_CHANGE_MODE_CLASS in df.c
Andreas Jaeger
aj@suse.de
Fri May 30 20:22:00 GMT 2003
We currently have in df.c uses of CLASS_CANNOT_CHANGE_MODE which is
nowhere defined - and also have the macro CANNOT_CHANGE_MODE_CLASS.
My question is now whether the code in df.c is wrong and we should do
a s/CLASS_CANNOT_CHANGE_MODE/CANNOT_CHANGE_MODE_CLASS/; or whether
that macro can be removed completly.
Michael and Daniel, the last ChangeLog entry is this one:
2003-03-20 Daniel Berlin <dberlin@dberlin.org>
Merge changes from new-regalloc-branch
From Michael Matz <matz@suse.de>
* df.c (df_ref_record_1): Move init of loc to safe point.
Only recurse on interesting things in parallels.
Handle CLASS_CANNOT_CHANGE_MODE smarter.
(df_uses_record): Ditto.
Are you sure that this is intented?
Andreas
--
Andreas Jaeger
SuSE Labs aj@suse.de
private aj@arthur.inka.de
http://www.suse.de/~aj
More information about the Gcc
mailing list