Another bit of ISO C conversion...

Kaveh R. Ghazi ghazi@caip.rutgers.edu
Mon Dec 8 03:30:00 GMT 2003


 > This can become
 > 
 > #if HOST_BITS_PER_LONG >= 64 || !defined NEED_64BIT_HOST_WIDE_INT
 > #   define HOST_BITS_PER_WIDE_INT HOST_BITS_PER_LONG
 > #   define HOST_WIDE_INT long
 > #elif HOST_BITS_PER_LONGLONG >= 64
 > #   define HOST_BITS_PER_WIDE_INT HOST_BITS_PER_LONGLONG
 > #   define HOST_WIDE_INT long long
 > #elif HOST_BITS_PER___INT64 >= 64
 > #   define HOST_BITS_PER_WIDE_INT HOST_BITS_PER___INT64
 > #   define HOST_WIDE_INT __int64
 > #else
 > #   error "Unable to find a suitable type for HOST_WIDE_INT"
 > #endif
 > 
 > which is simpler, easier to read, and easier to modify.  


Since you brought up this code in hwint.h, I was wondering...

Didn't we used to use HOST_WIDE_INT=int in some cases?  What happened
to that?

		Thanks,
		--Kaveh
--
Kaveh R. Ghazi			ghazi@caip.rutgers.edu



More information about the Gcc mailing list