m68k patch reviews
Peter Barada
pbarada@mail.wm.sps.mot.com
Sat Aug 23 03:13:00 GMT 2003
>The problem here is that a lot of Amiga source code already depends
>on the current attribute((interrupt)) behaviour. We can't just switch
>it that easily.
>
>If your versions of GCC haven't got too much exposure already,
>we'd better rename your flavour to interrupt_handler. It all
>depends on how much code depends on it.
I think the fiddes patches had 'attribute(handler)' support in them.
Please check the RTEMS patches to see what(if anything) was done there.
Also ask on the ColdFire list at wildrice.com before you usuper
attribute(interrupt) to be Amiga specific.
Perhaps you could create a m68k-amiga configuration that can usurp
interrupt(attribute) for Amiga's purpose and leave the rest of the
m68k universe alone.
--
Peter Barada Peter.Barada@motorola.com
Wizard 781-852-2768 (direct)
WaveMark Solutions(A Motorola Company) 781-270-0193 (fax)
More information about the Gcc
mailing list