missed uninitialised variable warning
Andrew Pinski
pinskia@physics.uc.edu
Mon Aug 4 16:31:00 GMT 2003
On Monday, Aug 4, 2003, at 09:56 US/Eastern, Andrew Pinski wrote:
> Here is a patch which should warn about more complicated expressions.
> If you want to limit gcc not warn about int i=i;, then add a condition
> in contains_exp
> for the case x==t and change the name of contains_exp.
This patch does not work with anything other than c and C++ because
walk_tree depends on the c front-end which
needs to change (and is changed already on the tree-ssa branch).
Thanks,
Andrew Pinsi
More information about the Gcc
mailing list