rs6000 3.1 Ada bootstrap problem

David Edelsohn dje@watson.ibm.com
Fri Mar 15 11:32:00 GMT 2002


>>>>> Richard Kenner writes:

> gnatpsta is referencing symbols which reasonably can come from
> that source, but does not link against it.  I do not know how the Ada
> developers want to address this problem.

Richard> Probably the simplest would be for rs6000.h to define
Richard> WIDEST_FP_HARDWARE_SIZE. 

	Define it to what?  WIDEST_FP_HARDWARE_SIZE is used in

Pos
get_target_long_double_size ()
{
  return WIDEST_HARDWARE_FP_SIZE;
}

In comparison to other functions in the file, get_target_bits_per_unit()
DOES NOT return MAX_BITS_PER_UNIT.  get_target_long_size() DOES NOT return
MAX_LONG_TYPE_SIZE.

	rs6000.h already defines MAX_LONG_DOUBLE_TYPE_SIZE, but
WIDEST_FP_HARDWARE_SIZE is not defined in terms of that.

	I do not know how Ada eventually uses these values, but the
context and name implies that Ada wants the active, in-use sizes, not the
maximum size the value can take.  Redefining WIDEST_FP_HARDWARE_SIZE does
not get around the fact that one needs rs6000_long_double_type_size to
know the size.

David



More information about the Gcc mailing list